Back to overview
Resolved

Some services are down

Jun 14, 2026 at 11:33pm UTC
Affected services
attendancegm.com
Attendance Tracking

Resolved
Jun 14, 2026 at 11:55pm UTC

QR Code scan is invalid org need to regenerate their qr code

Created
Jun 14, 2026 at 11:33pm UTC

update the landing page